iOS 15 sound-cutting-out issue [fixed]

Since updating to IOS 15 Ive been having an issue with the sound cutting out when using SM over bluetooth. This happens whether using the app or the web based version. And now the app won’t even load. I’ve reinstalled the app and it didn’t help. The only thing that helps is restarting my phone. Then it just cuts out again. I have another iphone that is still running 14 and theres no issue. Anyone else experiencing this?

UPDATE: These issues have been fixed in the latest version of the Strum Machine iOS app, which includes a from-the-ground-up rewrite of the audio engine that fixes the bugs Apple introduced in iOS 15. :tada:

You’re not alone. :confused:

Apple reworked their internal audio implementation in iOS 15 / Safari 15, and seems to have introduced a bunch of new bugs in the process. Many users have reported new issues in the past month, and they’re only happening on iOS 15 devices and/or with Safari 15 on a Mac.

The first big issue was that MP3 decoding broke for around 20% of users, meaning Strum Machine couldn’t load audio. :unamused: I had to bundle my own MP3 decoder as a fallback.

Now I’m hearing reports of more issues with sound cutting out, especially with Bluetooth. I’m still not sure what’s going on, and even more unsure if there’s anything I can do about it since the issue is definitely on Apple’s side of things, as these are new issues that aren’t there in iOS 14/13/12/11.

It’s good to hear from folks having these issues, so that I can have a better idea of how many people are affected and potentially get clues as to what’s going on. Thanks for posting and feel free to add any additional details as to what you’re experiencing if they seem relevant.

UPDATE: I reported the bug to Apple and they have identified the issue and fixed it… sort of. It will still take awhile for the fix to be included in updates to iOS and Safari. I’m hoping the fix will land in the next update, but I can’t be sure.

(Side note: this was my first time reporting a bug to Apple (here), and I was pleasantly surprised at how quickly it got addressed and resolved!

Actually, I have a weird workaround that may work for you. I’ve heard of two instances now where turning on “Guided Access” in the Accessibility page of the Settings app fixes other issues with Bluetooth speakers. I don’t know why, but it’s harmless to try. [Update: this doesn’t help in this particular case.]

Thanks Luke. I suspected it was the update. Here’s some more detail:

Iphone 8 IOS15
Problem occurred both within the app and the Beta. the Beta worked for a little while before cutting out.
The speaker I have the problem with is an oontz angle 3 ultra 5.0. I have also tried it with a set of Lava Cystereo headphones and wasn’t able to reproduce the problem, so they seem to work for now.

Haven’t tried the workaround yet but will let you know.

Just ordered myself an Oontz Angle 3 Ultra… not that I need another Bluetooth speaker! But hopefully I can reproduce the issue and come up with a built-in fix, and hopefully it will help with other speakers as well.

Let me know how the Guided Access workaround goes if you try it. Thanks! [It doesn’t help.]

So I encountered this issue with a Tribit XSound Go Bluetooth speaker that I have. After a solid hour of debugging, I finally tracked down the issue: the internal clock inside the Apple audio subsystem is running fast! For every second of real time, 1.84 seconds are passing in the audio clock. This happens not only in Strum Machine, but a blank web page with three lines of audio initialization/testing code.

I think the only thing I can do is file a bug report with Apple (edit: filed) and hope they fix it soon!

Your awesome Luke. TY!

Hi Dave/Luke:

I have had the same problem, ever since I updated my iPad OS to iOS 15. I am now using iOS 15.1 and the problem has still not even fixed. My work around to get SM to play, has been to turn off both the Bose Bluetooth Speaker, and the iPad. Then turn on the speaker first, then the iPad. Then go to the Bluetooth menu in settings, then click the connect button to reconnect the two. This is the only way that I have been able to get SM to play without disconnecting after the 2nd bar. It seems to be a glitch in iOS 15 and later, as this never happened before with previous versions of the iOS.

Donald Després

Looks like Apple is now tracking this bug internally and has marked it “REGRESSION (Safari 15)”, so at least we now know they’re aware of and are presumably working on the issue!

I am also having sound stuttering issues. MacBook Air bluetooth to Bose Mini, and iPhone 8 plus bluetooth to Bose Mini. It started a couple days after using the Strum Machine beta version. At first, I thought it was environmental interference; but I can listen to other sound/music sources i.e. (youtube, pandora) without issue. It is unfortunate. I was really enjoying the Strum Machine and the new beta features. However, I can only use it with a working computer or phone/speaker combination.
Good luck!

Does it resolve if you go back to the non-beta version? I thought it was unrelated to the beta, but if it’s only happening in the beta that would be interesting to know.

Are you using Safari on both devices to access

I only use Chrome on the computer. I will check the non-beta when I get a chance.
Thank you for your response.

There seems to be a non-bluetooth related problem: I run SM either over the iPad internal speaker or wired to an external speaker.Until today everything worked fine on my iPad (iOS 15.1). This afternoon, when I launched SM, a “An update is available” message appeared. I acknowledged it. And from then on nothing works: When I start a song, the count-down is ok, but then the sound cuts out and the blinking indicator that denotes the currently played chord rushes forward (approx twice the selected tempo), and the “Audio issue detected” message appears.

Since the problems started only after SM upgraded to (I had run the prior version on iOS 15.1 since last week without any problem), I think a bad version was pushed. Luke, is there a way to revert to a previous version, because right now I can’t use SM on my iPad

In SM, the version is shown as 344.6, Interestingly in the AppStore, SM still shows version 1.344.5

Update: I just deleted SM from my iPad and reinstalled it from the AppStore, and it seems to run normal. That means today’s push is somehow bad.

The only difference between 344.5 (or 1.344.5) and 344.6 is that I added some code to detect if the sound-cuts-out/rushing-forward issue is occurring, make a note in the logs, and display a message to the user. Nothing has actually changed in the code that plays audio, so it’s not actually anything to do with a bad push. More likely it was that your device would have had the issue today even if I hadn’t released a new version. And deleting and reinstalling the app was a sort of “reset” that fixed the issue, although it could very well have not fixed it. It’s a very “off and on” issue – I’ve found that it will go away and come back randomly when I reload the app, but haven’t figured out a pattern yet.

I too encountered the issue when not connected to Bluetooth once. In that case, the issue resolved itself when I connected to a Bluetooth device, and came back when I disabled Bluetooth. So it’s a very strange issue indeed.

I was able to reproduce the issue outside of Strum Machine with just a few lines of code (which you can see in the WebKit bug report if you’re techy and curious) so I know it’s something that Apple needs to fix, unless I can figure out a workaround (which seems technically impossible, unfortunately).

@DavidBargainnier, I’m assuming when you say “sound stuttering issues” you’re not talking about the sound cutting out completely like others in this thread are talking about… or am I wrong?

The sound just glitches and briefly skips, so as not to be in tempo as the song continues.

I still need to spend time comparing SM and beta SM on computer and iPhone to give you more useful information.

Luke - your explanations make sense. In my post I simply wanted to draw attention to the fact that the audio issues are not limited to Bluetooth speaker. It seems to be a general audio issue.

@DavidBargainnier Since you’re talking about a different issue, please contact me directly so as to keep this thread on topic. (Feel free to send a video of the issue, too!)

Everyone else: I’m happy to report that Apple has identified the issue and written the code that fixes it! It will still take awhile for the fix to be included in updates to iOS and Safari. I’m hoping the fix will land in the next update, but I can’t be sure.

In the meantime, @DonaldDespres’s workaround seems to be helping for most folks. It’s the best we can do while we wait for Apple’s bugfix to be released:

Turn off the Bluetooth speaker and the iPad. Then turn on the speaker first, then the iPad. Then go to the Bluetooth menu in settings, then click the connect button to reconnect the two.

Everyone: please update your Strum Machine app in the App Store (here’s a direct link). I just released the new version with a rewritten audio engine that should fix all the issues discussed in this thread. :tada:

Let me know how it works for you! Thanks!